Personal View site logo
Make sure to join PV on Telegram or Facebook! Perfect to keep up with community on your smartphone.
The Definitive Hackintosh topic
  • 359 Replies sorted by
  • @alcomposer Did you have to add anything extra to your boot plist beyond GraphicsEnabler?

  • Nothing out of the ordinary- (actually noting at all). All I did was use the Unibeast- then before I plugged in the 7970 I updated Chimera to the newest (also with Haswell support). I then set internal graphics (IGFX) to boot first- and to active.

    Then I plugged into the Mini Display port on the 7970, (currently HDMI is not working - only 2 display ports) but that is only a DSDT thing-(ie: writing a number 3or 4 somewhere) - which would be fixable- but now I have no time to play with that... will in future though- but I don't need HDMI anyway right now.

    Just to be clear no playing around with framebuffers or the like, (and I know they are working- 0 issues with FCPX - only one crash in 48hours constant usage, which is better than most people out there). Unigine Valley got an ok score I forget- something like 1500 for HD settings, (windows 7970 gets 2000 I think- it hurts bad that score!). And its not an overclocked 7970 either.

    Also do consider a MSI 7970 (Im not getting paid by them at all so don't worry) its just that they are probably the only company with Overvoltage support and also in the future they will support GOP vBIOS. You can actually update it now to GOP but that is another story- and Chimera doesn't need it- that would be for EFI boot.

  • Any thoughts/experiences about "TC Electronic Desktop Konnekt 6" firewire audio card on Hackintosh?

    Follow up: I bought used Konnekt 6 today, installed drivers from the TC site, hooked it up and it works like charm even without restart. All the inputs and outputs functional in sound setup in system prefs, control panel, effects, everything is working as it should be. Great interface, I must say.

    As for the squealing sound, I have that issue too. I have always thought that it had something to do with integrated sound card picking up some frequencies from the motherboard and transferring it to the speakers. But, now with new FW interface the sound is still there. It is coming from the motherboard, somewhere between GPU and CPU. It is more like chirp and it changes depending on CPU load I'd say, or some other load.

    Sometimes it just goes away, and it returns after few days.

    I've came across this info

    That's normal for some new boards. It's the toroids (see the coils around those ferrite cores). The copper coils buzz and fizz when they vibrate.

    Don't know if this might be the case here. Only I'm happier now when, with the new I/O card, the noise doesn't get transferred to the speakers.

  • Hey @inqb8tr,

    Yes that is the sound. Mine has gone away now, (almost miss it - thought that it was SUPER powerful with extra noise!).

    This is not a ground loop issue, this is a GPU issue - as they are getting more and more power hungry.

    TC Electronic Desktop Konnekt 6 can not be isolated- (there is no digital output) so if it comes back again... maybe get an additional ADAT interface? (PCI & Firewire available).

    This is what I have done, (was connected to my rig).

    Works really well - (don't tell anyone but Im using my Ultragain Pro 8- digitals for ADAT -> Speakers).

    The Pro 8's actually sound great, and if I was into spending any more cash I would get it modded by Black Lion as well. (quieter than an Apogee supposedly).

  • Anyone getting constant (coreaudiod) problems stopping the sleep function? It just started the past few weeks with me and I didn't add anything new. Not running spotify or any other crazy audio program, all other audio stuff is closed out too. Of course I can always go in and sudo kill but it's getting annoying.

  • This is not a ground loop issue, this is a GPU issue - as they are getting more and more power hungry.

    Did you try lifting off the ground?

  • @alcomposer is multi-screen on the 7970 working ok now?

  • @alcomposer Good to know the 7970 Just Works under Chimera without any added dickery. My 5870, being an Apple-approved Mac Pro option, doesn't even need GraphicsEnabler in boot plist to work perfectly. Never understood the backflips Hackintosh fora go through to get the latest Nvidia cards to work when there are serious ATIs that work OOB no fuss no muss.

    FYI the audio noise some of you guys are hearing from on board audio or PCI audio cards is ground related, but not a ground loop per se. It's a noisy ground being shared with the audio path. Since an audio circuit is only modulating the DC power supply at the end of the day, a noisy supply = noisy audio. Decoupling the audio circuit by using outboard D/A linked via optical cable is your best bet for a motherboard with noisy DC rails. Sometimes even just a cheap but decent USB audio adapter like the $11 Syba can get rid of this noise completely.

  • @shaveblog You're right. It's not a ground loop in the strict sense. It's noise travelling through the common ground. I have it even with my firewire MOTU interface. Lifting my active monitors off the ground (a tape over the plug contact will do) solved it.

  • @Shaveblog, thats what fixed it for me. But I don't have the machine now to play with :-(

    I can say that the noise stopped inside the case after it was left on overnight. So maybe it was burning in? I won't know until I test out that build again, (maybe in 2 months) :( :( :( I do know that the PSU I was using is most probably the best money can buy currently- Im not into Hackintoshes to save cash- Im into them to do my work- and I love OS X. (And OS X seriously loves them)

    But you are right- my rig was powered from a recording studio I use all the time, no ground loops normally. But I am almost happy to go ADAT from now on, the traveler is a NOISY POS. Apart from its great price (wait- I paid 1k for mine) and its great features (its is nice to look at)...

    Eh who am I kidding, will probably go with some new gen thing soon, but ADAT is all I need right now.

    @dtr, I haven't played with multi monitor yet - but both Mini-Displayport ports worked OOTB.

    Im not kidding- that 7970 is a beast of burden - love it.

    Now I have to plan yet another build during the interim... thinking of going z77x-up5th. (sorry - taking a risk with a 7970 was all I could swallow- Im sticking with what works, and quite frankly Haswell does nothing for me.

  • I'm trying to find some info online about a new problem I have. All of the sudden, my hackintosh renders as slow as my old MBP, the reason why I built this damn thing. I have no idea at what point it started doing this but all of the sudden it renders so damn slow, it makes me want to throw it out the window. Anyone ever experience anything like this? Besides formatting everything and starting from scratch, I have no idea what to do. Not really anything on Tonymac about this.

  • Are you using fx that is not cuda accelerated (in case of premiere)?

  • @vicharris,

    +1 dtr. Check out if your GPU is actually running in accelerated mode. (you can use the OpenGL tools in OS X Developer area).

    Other than that- reinstall on another HD (any will do- large flash card?) and test to see if the same problem is happening. If not- then check out the DSDT in your original build- possibly a corrupt setting.

  • @alcomposer Do you mean the OpenGL Viewer app in the Mac App Store, or are you referring to a different app? I don't have the same issues with slow rendering but am curious about the benchmark tools you're using to verify proper GPU behavior. I assume my HD 5870 Just Works because it's officially supported in Mac Pros and everything does get lots better when it's pushing pixels vs. HD4000, but it's always good to confirm these things if possible with test utilities.

  • @dtr

    I'm just using FCP7 actually. Not even taxing the system with AE, PP or Resolve.


    Thanks for the info. For some reason it's really hard to dig up any info at all on this subject unless its a windows build.

    Seems I'm having some odd problems in FCP7 as well, so the hunt begins.

  • What slows my PP rendering drastically is using non-cuda fx that is also not CPU multi-core aware.

  • @vicharris

    Check the Activity Monitor to see if something is going on ie. constant hard drive activity, a file being written...

    Reset preferences on FCP ie Scratch disks, etc.

    Run all items on Mountain Lion Cache Cleaner to see if it resets anything:

    FCP Maintenance Utility:

  • @vicharris in case you don't know this: open Activity Monitior Window>Floating CPU window and select one of the options. This will show you all of your system's processors. My hack is an i7 quad core (multi threaded) so 8 "processors" show up.

    When you render in FCP7 besides being 32 bit it can also only utilize 1 processor. So under "process name" you should see no more than 100% being used (which SUX!). The rest of the core are idle. This is what makes Premiere so attractive, on top of cuda acceleration and 64-bit, is it can use all 8 processors or 800%.

    In any event, what always worked for me was to use FCP rescue (discontinued) and save a set of the FCP prefs (I think there are 4) when the system was set up and running well. If it bogged down (well known prefs would get corrupted easily, you could quit FCP and use FCP rescue (or do it manually) and trash the current prefs and replace with your archived "fresh" prefs. Restart FCP and it would run well again.

    Also what OS are you running? 10.8.4? The last OS supporting FCP7 was 10.6.8. Anything beyond that and you are in unsupported waters.

    I am running 10.8.4 and have FCP7 installed, just haven't had a reason to use it yet. LMK how this comes out...? Thanks

  • FCP Rescue may not work with FCP 7. Use Preference Manager by Digital Rebellion here:

    Preference Manager allows you to trash corrupted preferences and keep backups of working preference files in order to quickly restore your settings.

  • Hey @vicharris the software I am talking about (now that I am on my machine with Dev tools installed) is Quartz Debug.

    Currently Apple have changed how the distribute the Developer tools. Once upon a time (before Xcode went App Store) it was all bundled together. Now you will have to get it from the developer tools download directly from Apple - its in the downloadable bundle named Graphics Developer Tools.

    You don't need to pay $100 a year to be able to download this. Simply register as a developer at:

    Don't ask me how to get to the download page. Its one of the links - but it always takes me about 4 mins to find the correct path to get to it. Just click away at the links until you get to a download place that has .dmg files. Search for Graphics.


  • Update on the chirping whining sound from motherboard: SOLVED

    I have set VCORE voltage from auto to constant. For now i have set it to 1.25V, and the chirping sound is gone. In the end this has nothing to do with hackintosh, only with gigabyte.

  • @ vicharris... obviously the dangers of using FCP on OSX after 10.6.8 are documented, even on real Macs. Recently I was forced to use FCP on my 10.8.4 Hackintosh and I ran into some stuttering problems immediately.

    Somewhere on a Mac Editing Forum someone suggested something odd, but it worked: change/delete the Waveform cache. In my case I switched the settings/cache to a different disk and there was an dramatic (!) improvement, albeit still with some hiccups. But in the long rung: FCP is done and gone... R.I.P.

  • @ninetto

    +1, for FCP projects buy 7toX, its the best $10 you will ever spend!

  • +1 on 7toX. I also recommend Xto7. Those two apps should be in everyone's arsenal if you ever want a flawless transition between apps of all kinds.

  • @ inqb8tr

    THANKS MAN!!! (I actually set my voltage to 1.25 independently of your suggestion - as I noticed that my vcore was running at 1.3V+ when overclocked to 4.5ghz) With my fixed 1.25V settings I also no longer get strange ramping up of system fans!

    Just checked with my Motu... no whine!

    spoke to soon, a bit of whine still... :(

    Oh well, I think that it could stop after a few days anyway...