Personal View site logo
GH1 .MTS file corruption - anything to do ?
  • Hello everyone,

    A long time user of these pages, I have been a member of this forum for nearly 4 years.

    I really enjoyed applying the camera hack for the GH1, which I use on an almost daily basis.

    I actually hardly ever had any problem, which is why I have made myself rare...

    What brings me to write today is the fact that I have these film clips that I was trying to edit into a single video : all of them taken with one hacked GH1, all .MTS (AVCHD "FHD"); one clip is 1h17m1s (time displayed in camera), and was divided into two files: 00005.MTS, size 4GB, 43m59s, and 00006.MTS, size 3.1GB, 33m1s (these two times are displayed in VLC); the second clip is 30m49s (00007.MTS, size 2.9GB).

    The problem is that file 00006.MTS displays a greened image right at its beginning (or sometimes a horizontal stripes pattern in millimeter spacing) for about half a second.

    And the worse problem is that, trying to work on the files with Kdenlive, I realized that file 00006.MTS just wasn't seen, the sections I used showed no video on display on the project monitor (even already on the timeline), and gave just white clips even before rendering (and after rendering as well). Trying to trim the first few images off the clip didn't work out, even converting the whole file to another format like .MP4 (with VLC) made no difference either. On the contrary the other two files 00005.MTS and 00007.MTS were fine.

    I thought of file corruption, looked here ( and there ( but wasn't sure if it was the same problem as mine. Similarly I am not sure whether the problem and the solution here ( is the right one for me...

    So if you have any information for me, whether it is a known problem, what might be the reason and the solution, I would be extremely grateful...

    Thanks a lot in advance.



  • 8 Replies sorted by
  • Post scriptum: Is there a particular setting of importance when you prepared the patched firmware ?

  • It is known that file spanning on hacked hg1 used to be trouble and no way back, but If you search really deeply on old posts you may find a way to kind of fix it.

    The best luck !!!

  • Hi endotoxic,

    Thank you very much for your answer. I thought of another possibility to solve this, going through the different related topics on this site. This is why I am opening a new thread/subject elsewhere.

  • Yeeeee you found the thread. I think nobody has been able to do Mts on gh1 to gh2. I wish the best luck. Keep on going!!!!

  • Hello everyone,

    I can proudly report that I solved my above problem! And this with ... of course ... nothing else than our favorite hacking tool - Vitaliy's "ptool3.exe"!

    Actually I was very recently able to meet somebody with another GH1 producing long AVCHD "FHD" films that could be edited on Kdenlive without any trouble. We took a look at the films on a computer and, to make a long story short, realised that one difference lay in one setting: while my films were "interlaced" the other person's films were "progressive"... Finally, it turned out that the other person had also hacked their GH1 with "ptool" and that they selected the option "AVCHD Movie Mode" --> "Wrapper" --> "Native 24p/25p"!

    So this is what I did as well, and it worked.

    Now I can look at times with long film sequences in AVCHD "FHD", that can be properly edited on my favorite video editing software...



  • Congratulations!! Well done!

    Don’t ever use interlaced. !!!