Personal View site logo
AVCHD gone ?
  • Hello everyone,

    I am new in this forum, so first things first: let me say "hi" to this very large family of modern camera users, hoping to spend time learning as much as possible with each and everyone of you!...

    I am a very happy user of a Panasonic Lumix GH1.

    Unfortunately with my GH1 I found a while ago that I couldn't shoot a single AVCHD video anymore; the remaining times to be filmed in the 4 AVCHD formats no longer appeared at all on the camera display; MJPEG still worked, and remaining times to be filmed did appear; none of the video movies I shot in AVCHD mode appeared in the browser (display) of the camera; on a computer, I was still able to access AVCHD video sequences...

    When I used another SD memory card to make an identical copy of the contents of the original SDHC memory card, the new memory card had the same problem; when I reformatted the other SD card anew, everything was suddenly fine and I could again shoot AVCHD films.

    All this leads me to believe that there was an exceptional circumstance that caused the camera not to record a certain data (just a byte?), in a certain "surrounding" file (metadata?) (it was quite cold on the day I shot that one AVCHD film which never got recorded). So the content of the card seems, for the camera, partially corrupted; and this error only affects AVCHD video sequences.

    Does this problem belong to the kind of things some of you could help solve? I am very much ready to answer your quesiotn if you need information...

    Thanks a lot in advance.


  • 9 Replies sorted by
  • I presume you have a non hacked camera

    Cold can damage memory but only temporally (if fluctuating temperatures are not extreme) also sometimes Gh1behaved strange in some circumstances m, like the dial mode on different settings.

    Have you upgraded the camera since purchace?

    If not then that may be the problem.

  • If camera is hacked and that appears that is strange... my gh1 died suddenly one time and had bad writing experience but was a bad motherboard. I know all the Gh1 where very advanced for it era, so many errors where made in that model.

  • Hello endotoxic,

    And thank you for your answer.

    No, indeed, my GH1 is not hacked yet ;-) The camera has had firmware 1.3 since I got it back late 2015.

    I was wondering if someone knew how "surrounding" files in /PRIVATE/AVCHD/... behave There are lots of directories and files in there; and one or several of them might have been affected (either not written or incompletely). Perhaps there is a way to reconstruct (size comparisons, checksums, or else) something?... Or not ?

    That is the question...

    Thanks to all of you.


  • The avchd file structure is mainly for the proper reproduction of the directory files since it can auto play it dvds and such drives.

    Private/avchd/bmdb/and then there is a final file where all videos are in mts forma not avchd. Avchd is the file format the conjunction of all that file structure composed an avchd file.

    hmm yup

  • Hello endotoxic and everyone,

    I was wondering: when in picture browser / playback mode, the camera browser/display shows exactly in chronological order what picture has to be shown, whether stills or movies.

    There must be a way for the camera system to know when and where to fetch which picture (still and movie).

    And there must be a file where it looks to find this information.

    I am looking for this file ("ordering file" or "chronology file"), as I believe that this is the file that was messed up at some stage, and still is in the present configuration of this SD-HC card (a newly reformatted card allows the camera to shoot AVCHD again), and the fact that this one file was messed up makes AVCHD films on that particular card invisible on the camera.

    Has anyone looked into this before? Has anyone a clue or a hint to give me?

    Thanks a lot in advance.


  • Hello everyone, hello endotoxic,

    So I have been taking a very close look at these directories and files that have to do with AVCHD pictures, comparing the affected SD-HC card with a newly formatted one.

    • sd-hc_card/PRIVATE/FILEINFO.TBL is a file with a fixed size that apparently never grows, but whose contents do change a lot.

    • sd-hc_card/PRIVATE/AVCHD/BDMV/INDEX.BDM and sd-hc_card/PRIVATE/AVCHD/BDMV/MOVIEOBJ.BDM are growing files

    • sd-hc_card/PRIVATE/AVCHD/BDMV/CLIPINF contains data in connection with avchd moving pictures, insofar as it has as many files as there are movies, the longer the movie, the longer the .CPI file

    • sd-hc_card/PRIVATE/AVCHD/BDMV/STREAM contains the movies, has as many files as the previous directory (see above).

    • sd-hc_card/PRIVATE/AVCHD/BDMV/PLAYLIST contain data in looser connection with avchd moving pictures, as it seems to have only one file per day of shooting - the more movies you shoot, the bigger the .mpl file; the last movie of the day closes/finalises the .mpl file for that day.

    And there in my view lies one problem on my card: I shot five movies on July 20th 2019, and file 00015.MPL which should have been written for that day is not there as such - it is there but very weirdly it is dated later, February 18th 2020 - which is the day I tried to shoot the last AVCHD film that never got registered, the day this problem appeared!

    So what I'm thinking of is this: on 02/18/2020 file 00018.MPL should have been written, instead of that it wasn't, and it was written as 00015.MPL, erasing the original 00015.MPL originally dated 07/20/2019.

    Next step is try to compare these .MPL files, especially those with similar sizes (on days when a small number of movies were shot)... But it's too late for now...

    Anyone got an editor, software for examining such files?


    Thanks for your help.


  • Hello everyone,

    Long time no hear nor read.

    I had actually given up on this one - except that I was recently confronted again with the exactly same problem with another card!

    My conclusion is, for now, that the problem appears when the card is about to get completely full: in the last 10% of the card it seems to be impossible to shoot AVCHD films.

    So I will take it easy and bear with this.

    Thanks anyway for helping out.


  • it could be the card transfer speed drops below a certain threshhold when it gets too full. you could try a faster card. or maybe the file system is FAT32 and has 4GB limit?

  • Hello hardimpact,

    Well the cards I used were: when I noticed the problem the first time a 32GB card, and the second time more recently a 16GB.

    But you might definitely have a point with your first remark, yes. The two cards had the same speed (90MB/sec).

    Indeed, MJPEG still works when AVCHD no longer does.

    I'll try with another speed category next time.