Personal View site logo
Z-CAM E1 Camera 100 Mbps hack for 4K DCI (fw v0.31)
  • 382 Replies sorted by
  • @adybady sorry....when I saved as, after bringing up the raw , and put that file on my card, I got well over 100mbps for dci with multiple samples, as have others. So it works. Start again with a freshly formatted card. And the v31 firmware I believe I downloaded from zcam fb page. If your camera is running 0.31 then your fw has to be good. I did get stuck for a while until I learned how to get the correct file off github, and when I had the wrong format of the file, it appeared to me at that point to also not work. So chances are that's your weak link.

  • Guys, sorry for my big delays between messages. I'm very busy with "true-resolution slow motion" hack. Still can't find what registers I need to change for MN34230 sensor. Where can I find documentation for this Panasonic sensor? Any ideas?

  • Thanks @kurth I got it working. Saved directly from the browser on the raw page at github did it.

  • cofhal

    You can check the bit rate of a recorded file by looking at its properties. On the second tab of the details it should show you the bit rate stock it should be around 60,000 if the patch is working 100,000

    let us know what you find?

  • kurt and adybady can you guys post a link of exactly where your getting the files because I haven't been able to make it work yet!

  • Just found this thread -- pretty amazing work, storyboard.

    For those having problems creating their own autoexec.ash file, in Windows I had to delete the carriage return characters, but keep the new line characters. I also made sure the last line was followed by a new line. Either way, it worked after I made those changes.

    If just copy/pasting from Github, Windows might insert /n/r. I used Notepad++ to remove them by replacing /r with nothing. I've attached my custom ASH for example that works; it just needs to be renamed appropriately.

    Side comment/question/request,

    It was mentioned on page 10 that Storyboard saw support for 4K over HDMI? For the life of me I haven't been able to get 4K to work over HDMI yet with the E1; just 1080p. My 4K capture device works great with my Panasonic G85, clean 4:2:2 4K out over HDMI, so I'm not sure its an issue there.

    Considering how hot my ZCAM E1 gets when recording to SD card @ 4K, I'm hoping to instead record over HDMI to try to reduce the load on it; perhaps do some real-time noise reduction with my Nvidia RTX prior to compression.

    356 x 343 - 14K
    605 x 334 - 15K
    428 x 319 - 304K
  • Hello @ storyboardcreativity Do you have anyone who has an E1 with display damage?

    a possibility found the internal display s.Hdmi output output or the wlan automatically turn on

    izugar uses a configuration file for the E1 Remote

    Cool would be too

    Configuration for STA mode -> E1 connects to wireless router (Settings zz only possible with IPHONE)

  • E1 CFG Data-->linux type cfg. data type not load in forum... call me i send with mail

    746 x 748 - 113K
    893 x 270 - 34K
    261 x 139 - 14K
  • I am still having trouble downloading the autoexec.ash file from the site. I click on the Raw button and then when I try to "save as", the file saves as autoexec.ash.txt file. What am I doing wrong? Or what's the best way to download that file in the proper format?

  • -> Go to the file you want to download.

    -> Click to display the content within the GitHub UI.

    -> press upper right on RAW key .--> pic 2

    -> Right click -> Save as ... -> pic 3 and change the name From--> autoexec.ash.txt !!

    --> To -> autoexec.ash <-- delete the ending -> .txt !!!!!!!!   Tip ---> create a folder with subfolders with the respective name !!! because all files are called autoexec.ash

    403 x 288 - 24K
    400 x 229 - 27K
    359 x 207 - 17K
  • --> the easiest way is --- Ever ( :-) <--

    -> go to the start page -> as in the picture

    -->and use the function -> clones and Save right in the green field

    -> and download everything as a zip file

    -> save it on the desktop

    -> then you can copy the respective autoexec.ash from the respective folder --> to Camera

    1036 x 419 - 65K
  • I have the camera updated to .031 and I have tried downloading the zip file and I have tried getting the file using the raw button then "save as" and I am still only getting 57837kbps.

    What the heck am I doing wrong?

  • 1.) 100% function my Tip: > use the function -> clones and Save right in the green field

    2.) THE HACK Switch from --- constant Bit Rate to variabel Bit Rate

    3.) 100 Mbps Max Bit Rate on 4k30p with many many moving in complet Pictures

    Read this Chat from site 1 to site 11 and you found all over this Hack

  • Ok I just went to my SD card and opened the autoexec.ash and this is what I have on my card.

    Strangely whats showing here doesn't show the # that are present at the beginning of each paragraph.

    change VBR max percent from average bitrate

    writeb 0x04136E94 0xA0

    4K UHD 29.97 fps

    writel 0x044CAF00 0x03E7FFFF writel 0x044CAF1C 0x00000001 writeb 0x044CAF20 0x03

    4K UHD 24 fps

    writel 0x044CAF54 0x03E7FFFF writel 0x044CAF70 0x00000001 writeb 0x044CAF74 0x03

    HD 239.76 fps

    writel 0x044CB0F8 0x03E7FFFF writel 0x044CB114 0x00000001 writeb 0x044CB118 0x03

    HD 59.9401 fps

    writel 0x044CB1A0 0x03E7FFFF writel 0x044CB1BC 0x00000001 writeb 0x044CB1C0 0x03

    4K DCI 25 fps

    writel 0x044CB3EC 0x03E7FFFF writel 0x044CB408 0x00000001 writeb 0x044CB40C 0x03

    4K UHD 23.976 fps

    writel 0x044CB494 0x03E7FFFF writel 0x044CB4B0 0x00000001 writeb 0x044CB4B4 0x03

    4K DCI 24 fps

    writel 0x044CB788 0x03E7FFFF writel 0x044CB7A4 0x00000001 writeb 0x044CB7A8 0x03

    4K UHD 25 fps

    writel 0x044CB92C 0x03E7FFFF writel 0x044CB948 0x00000001 writeb 0x044CB94C 0x03

    FullHD 50 fps

    writel 0x044CB980 0x03E7FFFF writel 0x044CB99C 0x00000001 writeb 0x044CB9A0 0x03

    FullHD 25 fps

    writel 0x044CB9D4 0x03E7FFFF writel 0x044CB9F0 0x00000001 writeb 0x044CB9F4 0x03

    HD 50 fps

    writel 0x044CBA28 0x03E7FFFF writel 0x044CBA44 0x00000001 writeb 0x044CBA48 0x03

    FullHD 25 fps

    writel 0x044CBB24 0x03E7FFFF writel 0x044CBB40 0x00000001 writeb 0x044CBB44 0x03

    HD 119.88 fps

    writel 0x044CBD1C 0x03E7FFFF writel 0x044CBD38 0x00000001 writeb 0x044CBD3C 0x03

    FullHD 24 fps

    writel 0x044CBE18 0x03E7FFFF writel 0x044CBE34 0x00000001 writeb 0x044CBE38 0x03

  • Unzip the File and Copy the ash File from Folter to micro cf Card ........And use it

    !!!!!!!! to learn what you are doing .... read the chat history from the beginning.

    !!!!!! that's hard ... but that's how you learn

    storyboard has answered all your questions at least once already

    1920 x 1200 - 447K
  • I reached out to several of you on this board and xyster who is cool cat emailed me his patch file and it worked first try 105 MBS per second! So something in the downloading process is affecting the files.

    Thank You again xyster for your help!

  • Finally, something that was needed when the camera cane out.

    Has anybody manged to overclock the circuites to get 4kp48/50 at 2.41:1 ratio (to help reduce the amount of overclocking needed), or to try a little under rez window at 2.41:1 to get it closer again to normal?

    One of the developers told me the camera uses a 1080 HDMI part a long time ago, and that's why it's limited to 1080. If only the camera could have done 200mb/s 4kp50/60 with a little better pixel format, with clean HDMI out, can you imagine what a camera it could have been?

  • @mei Yes, I can imagine. It's the Z Cam E2C. $799.

  • Imagine back then, when that was much more important.

  • Thanks vitali i Transfer

    1600 x 1600 - 176K
  • @Bob_Hawk

    We have nice separate topic for this lens -

    In hack topic it will be few people who will find your note.

  • Hi all, Just picked up m ZCAM e1 again for the first time in a while and tuning into this thread. Can someone summarize what has happened here? Apologies as I don't really follow alot of the lingo. I'm particularly interested in anything at 48fps or 60fps with improved bitrates? Was that achieved?

    Can I download a hack somewhere and try it on my sd card? Thanks for any help !

  • @orey10m....jump thru the hoops like we all did

  • Amazing thread and amazing results. Thanks guys for all the effort you've put into it!

    Would it be possible to activate the hack on the 4:3 (30fps) resolution? and also on the 2432p (30fps) 1:1 resolution (izugar firmware)?


    520 x 420 - 43K