Personal View site logo
Panasonic GH5 V 2.0 and up firmware topic
  • Topic dedicated to firmware improvements, samples and issues discussion.

  • 96 Replies sorted by
  • Tried ALL-I on sandisk 95mbs V30 joy..stops recording after 10 seconds..

  • @Imackreath I was written, that a V90 cars is required.

    I updated and when I wanted to watch the footage, the camera message popped up: This battery pack can not be used: It is an original Panasonic battery back. That is not good. I am charging my other battery packs now to see, if it shows the same message. I have 2 more originals and 2 mor 3rd party.

  • I"m so far very impressed with the Mp4 HEVC HLG 72 mbps mode. 10 bit 4:2:0 very clean in the shadows and will be great for long recording. So much to play with!

  • @AKED

    You mean what Panasonic added third party battery bomb in firmware?

    Bad guys.

  • @AKED yeah i knew you needed a v90, just wanted to try my luck with a lesser card as the v90s are so expensive..

    I was using an official panasonic battery...had no issues

  • @Imackreath I did the same thing :-). Just to check and got the same message.

    @Vitaliy_Kiselev I have 3 original Panasonic battery packs. One came with the GH3, one with the GH4 and one with the GH5. So they are all original Panasonic and can not be fake. The pack from the GH3 had the message. I an charging the GH4 and GH5 battery packs right now to see if they work. 3rd party battery packs I can check in the next days.

  • I'm using a 3rd party battery with no problems.

  • GH4 battery pack seems to work.

  • GH5 battery pack works. And after I also tried the power Adapter DCC12 (which worked fine), I put the GH3 battery pack in the camera again and now it works. Strange. Before I had the message 5 times in a row, always about 1 - 2 seconds after the in camera playback started. Very strange.

  • Can be bad contact and as it start recording voltage drops, it can't get response and stops.

    Camera logic is as follows. If voltage is above certain it assumes power as DC source and works. IF voltage is lower it assumes this as battery and start communicating with chip inside. If response is wrong or response is absent - it show this thing and stops.

  • interested in sd card tests against all intra 400mbps...I hear some tests have shown that the lexar 1000x work fine and they are not marked as v90 or v60

  • The camera refused the battery only during playback. Not during recording! I recrede 3 or 4 clips with that battery pack, befroe I wanted to have a look at it. Then the message came.

    Anyway, it was fully loaded. I had this battery in the GH5, when I updated to the 2.0 firmware. And this is only possible, when it is full. Otherwise the camera refuses the update. I will monitor this.

  • v2 upgrade went fine. Tested 400Mb with Lexar x2000 card and had no issue. Can't wait to play around with it.

  • Tried All-I on Sandisc Extreme Pro 95mbs. Filmed trees with no panning. Managed one shot 17 sec and one shot 30 sec with no hickup. Tried same but now panning medium speed. The camera stoped recording after about 20 sec with the message "stoped rcording due to limitation in card speed". This was expected. All files including the stoped ones could be read and viewed in camera.

  • The firmware's release notes specify that a v60 card is needed for all-i mode (and that v90 is suggested for loop rec in 6k photo). I have both a v90 and a v60 card on order so I should be able to verify that tomorrow. With my Sandisk Extreme uhs-3 card, I get about 20 seconds recorded before it bombs in 400mb mode, but 150mb mode works fine.

  • I updated to version 2.0. Tested ALL-I. Used Sandisc Ultra Pro 95 MB/sec. Shot one scene for 17 secs and one for 30 secs. Trees no paning. Both worke. Tried same but now panning medium speed. The camera stoped recording with the message of limitid write speed on card. This was expected with this card that should not work. All files could be played back i amera. I am surprised!

  • It worked with 3rd party battery pack. So it seemed, that it was kind of a problem of an older battery pack.

  • Wow! The IS lock function is insanely good from my initial tests. Cannot believe how locked down it makes the image - I feel like this is what IS is supposed to do. Much less floating so long as you are holding the camera steady - definitely not designed for using with camera movement. More to emulate a locked down tripod shot while handheld. Dual IS mode has too much float to get a true lock down feel, but this new IS LOCK mode is great.

    I do like that you can now map the audio levels control to a Fn button - but it's poorly implemented - yes you can do it while recording, but it blacks out the entire screen when the audio controls come up. Really wish it just activated same audio control screen that comes up with the Touch Tab enabled.

    727 x 574 - 138K
  • Initial AF tests are much more promising than I imagined. MUCH LESS hunting to the point of feeling like Dual-Pixel AF. Sure there will still be haters but this definitely an improvement. TBH, I rarely use AF for video, but nice to know they can make it better via firmware.

  • Good report from

    Here is dual pixel c200 report

    and here gh5 yesterday

    object tracking appears to be where the effort has gone and also note, people wearing hoods and hats might not be the best for fd :(, just use object track as recommended here, also, they are still not 100% confident, when it counts, in af period, even with dual pixel af and dedicated lens!

  • test here too

  • @sam_rides_a_mtb 100% agree , did some test and AF really improved , and I.S. lock video stabilizer work really fine too.

    Of course my sandisk extreme 90mb/s v30 64GB its no working at 400mbps.

    Does anyone know how can import or transcode Mp4 HEVC HLG 72 with Final Cut Pro X ? thx

  • @adventsam in the 1st vid you posted crazy warping in the footage.... is that a panny lens....? dang....

    Focus hunting with the noctitron even in the V2.0 update lol!

  • @chef

    He looks fun, and test is strange.