Personal View site logo
Sony Alpha hacks talk
  • 248 Replies sorted by
  • @colsub it seems that the GUI you are using has some issues, try installing the tweak using safari (mac)/internet explorer (windows).

  • what is the latest version and where can we find it ? Its not working for 6500 and 4k version 0.9

  • I have a live shoot coming up next week. I see one person confirmed it working on the a6500 and another who did not. Can anyone else confirm this working on the a6500? I haven't bought one yet but I will buy the a6300 and shoot in 1080 if I have to. I would prefer to shoot 75 minutes in 4K with the a6500. Thanks.

  • @sleepinghouse I believe it's working on the 6500 in 4K even though the menu option "Disable 4K video recording limit" is disabled. This is also the case with the A7SII/A7RII on the latest firmware.

    You'd need to check "Disable video recording limit" and test recording past 30mins in 4K for peace of mind.

  • Hey !! I recently bought Sony a6300 in Japan .and I can't change language ofcourse so I tired the hacking tricks that u have given. I did everything needs to be done but when I click on install and afterwards it says device error: SSL What does that means?? Can u explain what went wrong??i really need it.

  • So I've managed to brick my NEX-5N trying to perform a custom firmware upgrade after fiddling with the ext2 filesystem image. It doesn't show up any more via USB and the access light near the battery compartment blinks a long long long short short pattern over and over until the battery is removed (see http://i.imgur.com/d5KgHwJ.gif)

    Does anyone know if there's a way to put the NEX-5N into a DFU mode or force a firmware upgrade? Otherwise might be time to break out the soldering iron.

  • star trails and double exposure apk-s, maybe somebody want`s them http://www.filedropper.com/startrail131 http://www.filedropper.com/doubleexposure120

  • Hello, pynk6! Thank you for this apps! Works well on Sony RX10m2! Can you upload other apks from SonyMarket?

  • I have just these two, maybe someone else had others :)

  • I've just loaded the new 1.01 firmware of A6500 and can confirm that the patch is still working with it. :-)

  • I thought I'd try an experiment... Hooking up a 22" touchscreen to the a6500.

    The touchscreen, unfortunately, did not work. However, it does work with no problem on an android tablet I have, with HDMI out. I assume that there is a driver or two missing in the a6500 that would allow this. Would it be possible to add those OTG/HID drivers to allow mouse/keyboard/touchscreen support?

    With touchscreen support, you could have an off-camera large screen touch-to-focus system on the a6500.

    Just a thought.

  • New version of OpenMemories-Tweak is out and has added "ADB Switch" in the release notes. Which I believe is "Android Debug Bridge".

    May be useful for some? Great to see that this is still continually being improved.

  • Hi, i've same question with @jaygar. Will it work on a6000 FW 3.20? Thanks!

  • @lukill, yes, I was able to able make it work with my a6000 FW 3.20.

  • @pynk6 , sorry for asking, how do I manually install the apps ?

  • Long story short; as an underwater photographer I buy 2 bodies to prevent a housing flood from ruining a dive trip. When the NEX7 was released there were supply chain problems. I was only able to source one NEX-7 body from America and the backup was from the Dubai Duty Free. The US version flooded 2 weeks ago and I am left with a PAL Nex-7 Body. Is there a way to change this body to NTSC?

  • I could install the tweak app on my RX10ii and is was working well. I´ve enabled telnet and wifi and could connect and browse the directories. Unfortunately I turned the camera off without disabling the wifi. Did this 2 times already and everything ok, but this third time, the camera died. Now I can switch on or off, nothing happens screen remains black. The red light is on the whole time. When I remove the battery, the ligtht is off, but when I put the battery back again, the light is on again without switching to on, when switching to on, nothing happens.

    Any ideas here?

    Does the RX10ii has a kind of hard reset? Can the firmware be deleted accidently? That should not happen.

  • Is there a way to change this body to NTSC?

    @BangkokPhoto there is no way, unfortunately. Either convert it into 24p in the PP, or get rid of the PAL Nex-7, like I got rid of mine.

  • /re from beginners

    Hello, and first of all thank you for great research you did on hacking Sony cameras. I want to change language on a JDM RX10 mk1. AFAIK openMemories does not work with mk1, only starting from mk2, so I try to follow your guide http://www.personal-view.com/faqs/sony-hack/languages. Everything is ok till Part 2.

    I modified tar and recompiled it (I was able to compile only latest version, 1.29), however when I try to pack firmware back with recompiled tar it makes different archive. Actually it makes exactly the same archive as original, unmodified tar.

    Can you suggest what can I try? Or probably new tar with different headers will still flash to camera?

  • Well, it turned out modified tar file flashed without any problems. But, unfortunately, as already mentioned here, file swapping method does not work on Gen3 cameras any more. There are menu files in /nflasha15/share/app (like string_english and string_english_guide.uxc).

    This raises some more questions - will simple swap of string_japanese with string_english do the trick or menu files do not work this way? And, main problem now - was there any development on lzpt compression since last release or it was abandoned in decompress-only mode? :S

  • Okay, I managed to fix that without modifying flash partitions. Messed with backup settings file header and suddenly it worked. Still no idea what exactly needs to be modified but looks like byte at 0x38 offset is file version and needs to be incremented for camera to read it.

  • Just find lots of debug calls in NEX5N_v0102_av-cam !

    ScreenShot.png
    864 x 540 - 40K
  • Hello, I have a big problem with using the video buffer hack play memories tweak. My setup is: Alpha7 (first generation, Firmware 3.20) I was able to install the app to the camera (the menue looks a little different to the once s I saw on youtube), and was able to switch from 30min to 13h , but the camera still stops at 29:49h. I am wasting already days on that. Can somebody help me???!!! I would be very grateful for help. Roger

  • Hello all,

    Since we know that disabling "long exposure noise reduction" is possible with the openmemories framework (BetterManual does it), and that the A6000 even has a menu setting to disable it, would it be in any way possible to disable the setting globally also in A5100, which has hidden the option from the menu in order to purposefully gimp it down to "more user friendly"?

    This is mostly bugging me with the Timelapse app. It is basically useless on A5100 and they didn't tell it to me before purchase. It was a waste of money. If there was apk available for this, would it be possible to modify to have this setting forced on, if not possible to set globally with openmemories-tweak or similar?

    All ideas and theories are welcome!