Personal View site logo
Sony Alpha hacks talk
  • 249 Replies sorted by
  • this app work with A6300 ? tx

  • What he asked ^^^^^^^^^^^

  • @ma1co Thanks for your great work.

    When changing the setting from PAL to NTSC (on PAL devices) and visa versa on NTSC devices, the Sony digicams come up with the nasty message 'Running on NTSC' which needs to be confirmed before the camera can be used. Do you thing you can change this to suppress this absolutely unneeded message?

  • I totally agree. If you can get this NTSC/PAL message to be disable. It will be awesome.

  • I got the tool, set the USB to MTP mode, downloaded the plugin, was able to run the tool but got the network error. Then I looked in the list of supported cameras and found out it's compatible up to NEX6 cameras. Any news on whether this tool will work on NEX7 cameras?

  • ma1co, I have a lot of respect for your skills. I've tried NEX-6 and ILCE-6000, using Windows 7 and IE 11. I had to retry a few times, but finally it worked. When it didn't work with the Tweak app after a few attempts, I installed the Demo app first, which worked, and then the Tweak app could be successfully installed, too. I was able to remove the 30 minutes video limit on both cameras. I successfully recorded around 1 hour and 45 minutes with the Alpha 6000, using AVCHD and the lowest quality setting (25p, 17mbit), until the battery was empty. Thanks a lot for your work. Please suggest a way for us to buy you a pizza.

  • The site seems to be down - is this temporary or permanent?

  • Yep, got a 404. Sony's coming down hard on this with a cease and desist?

  • Heh. Good luck with that Sony. Looks like they're shit scared of someone unlocking the raw video capabilities they're deliberately holding back to maximise their profits. To hell with that.

  • Looks like they're shit scared of someone unlocking the raw video capabilities they're deliberately holding back to maximise their profits.


  • @ma1co What's going on? Did they shut you down?

  • Google suspended the site. I'm trying to find out why exactly.

  • Next can be github, they are famous for instant bans.

  • Works on RX 10 mk2 firmware 1.30! So great! Amazing work @ma1co - would really like to donate to this work if possible, it really helps in day to day work.

  • Works like a charm with my A7S. Thank you very much!

  • So I have tried running multiple times via Safari since I'm on OSX and keep getting this error (Photo Attached).

    What does Error: Network Connection imply?

    I am definitely connected to wifi via my rMBP running this app. Trying to make this work on the A7R.

    Also, anyway to unlock UNCOMPRESSED RAW in the older models prior to the A7II, A7RII, A7SII?

    Screen Shot 2016-04-30 at 7.25.04 PM.png
    1252 x 568 - 53K
  • @mattryandp Are you using the usb cable that came with the camera? Don't know if it will help, but firmware update fails when using standard usb cables.

  • Uncompressed RAW? They already overheat with far less ;-)

    Are you sure you set the camera to the right mode? It normally starts up as USB mass storage, you want to switch from that.

  • Someone over at DVinfo managed his RX100 mk4 to record 79 minutes without any overheating :-)

  • Having problems connecting camera to Mac? Sony doesn't support OS 10.11 El Capitan. Useful article here:

  • Apparently others on OSX 10.11 (El Capitan) are having issues. So it might be the os version issues.

    Uncompressed RAW stills... not video. The new models have Uncompressed RAW for stills as an option.

    Yes, camera was and is set to MTP mode.

  • I experienced the "Network Connection" error on 10.11 with multiple cameras. Couldn't get it working with the Sony site either. Perhaps the Photos app background process is intercepting the connection as the camera is connected to the computer.

    I simply followed the instructions for doing it with the terminal command line and everything worked fine.

  • It was on Yosemite and I tried the demo first. Maybe that helps?

  • Hi, I just need to buy a camcorder.. I Will have overhetting problems if install this hack on rx10 ver.1 ? It will be better than canon g30 ? ( fluid zoom and low light ) . Thanks a lot!

  • Is there a relatively simple way to get telnet or adb running on a Sony camera? Also, is there a way to enable WiFi and keep it enabled without an app open?

    I suppose I could try to write an app that includes a Java telnetd implementation, but I'd rather not learn to write Android apps just to get telnet running. I will try if I have to, but I thought I'd ask and see if there's an easier way.