Personal View site logo
Make sure to join PV Telegram channel! Perfect to keep up with community on your smartphone.
Diagonal rain appears using GH2 + Premiere Pro CS6 without a hack
  • Hi,

    I've been trying to work out why exporting some noisy low light footage in premiere pro CS6 is giving me 'diagonal rain' problems that aren't present in the original m2ts files from my GH2.

    Reading two similar topics (below) the problem seems to be related to GOP length, which hack is being used, and the decoding abilities of certain players. But I shot this footage with the original firmware so this can't apply? Possibly it is a CS6 specific issue?

    http://www.personal-view.com/talks/discussion/5120/please-help-problem-with-my-gh2-footage/p1 http://www.personal-view.com/talks/discussion/3804/strange-pulsing-diagonal-pattern-in-gh2-hack-footage/p1

    It's not footage I can take again so any advice on how to export this without the noise would be amazing... I'm a beginner but not posted it there as the problem seems to be a complicated one.

    I just uploaded the start of my edit to youtube for an example of the problem. Some of my footage was 24p and some was 50 fps 720p but the problem persists in all the export formats I've tried;

  • 115 Replies sorted by
  • Transcode with 5DtoRGB before rendering your edit (replacing footage) or before importing to edit.

    No more rain.

  • @BurnetRhoades that's great, thanks! The clip I want sequences from is 9 minutes long, any cutting tools you recommend so I just transcode the portion I'm interested in?

  • I'd just transcode the whole thing and then free up the space once you're done. The tool I always use for that sort of thing doesn't read MTS directly (QTPro Player) or does with an addon so bad I finally got rid of it so that I wouldn't actually make the mistake of ever playing MTS with the QT Player again.

    5DtoRGB is currently the only tool I trust to not muck up camera-raw MTS files. Sorry.

  • No worries man, just glad there is an easy solution! Cheers again

  • you can split your mts file into various segments of any predefined length, for example (see screen shot 1) 9 minutes split every 15 seconds splits your original file into 36 new files, they will be split as mt2s, but you can just rename them mts. Use tsMuxerGUI if your on a mac to do this. you can also join back sequential clips (2nd screen shot) using the same program if you need some sections to be longer than your predefined split length.

    all this is easy if you preview your master clip and roughly decide what parts you'll be using. no need for huge files when up converting

    Screen Shot 1.png
    661 x 673 - 79K
    Screen Shot 2.png
    663 x 674 - 134K
  • Thanks @eyefi, I'm on windows so will have a look for a win equivalent to tsMuxerGUI.

    [@BurnetRhoades - I transcoded a file into a .mov with the default settings as it was all unfamiliar to me (Apple ProRes 422 23.97) but I can't play the file with WMP, VLC or SplashLite.

    Any suggestions for what transcode settings I should use?]

    Edit: Output file is working using the Avid codec and saving to .avi

    Thanks

  • I can't belive how many people considered @LPowell's amazing patch Flowmotion to be a problem, but it is obviously Premiere's developing team who can be blamed for digital rain. I hope you all Premiere users guys contact their support and report the digital rain problem? It is clearly an issue to be fixed.

  • @PeterParkorr the ProRes file would play back in Quicktime. It should also load into any editing app that reads Quicktime, like Premiere.

    Perhaps you'll have better luck with DNxHD but there were no options for it and I could only get 5DtoRGB to write out the Avid files with embeded "zebra" pixels that showed up in several shots so I went back and re-did all my Avid transcodes to ProRes HQ.

  • @tetakpatak: Myself amongst them. I did mention at the time I'm seeing a semblance of digital rain even with stock firmware (but I only tested a well lit scene). I have trained my eyes since to see the rain in any lighting - it's still there if you know what to look for.

    The problem apparently lies only indirectly with CS6 - someone else on this forum investigated and discovered it's a MainConcept decoder fault; he couldn't find a way to override DirectShow decoder weightness - so CS6 is stuck with it.

    They (MainConcept) will fix it eventually and it will make its way to Adobe...it is interesting though that not ALL patches have this problem; for example Valkyrie 1.3 decodes perfectly well - I haven't tried anything else.

  • @PeterParkorr, you can use this on a pc, http://www.bunkus.org/videotools/mkvtoolnix/doc/mkvmerge.html it looks like you can do most of your split and join all in one task. see: "2.5. File splitting, linking, appending and concatenation (more global options)"

    specifically this (see screen shot)

    you'll probably just have to change the container from mts to mkv on TSmuxer(pc)

    Actually TSmuxeR seems to be sufficient to do all you'd want

    Screen Shot .png
    1023 x 921 - 206K
  • @BurnetRhoades yeah, the .mov wouldn't load into Premiere (I think? It wouldn't play even in QT but can't remember if I tried loading it into the sequence, damn), and the Avid .avi registered as only an audio track, no video included, even tho I could watch it in a player. Could some of my issues be to do with Premiere still being in Trial mode? I've only just installed more codecs from K-Lite (changed my laptop since I was last editing video...) so that may have been part of the problem. I will try again and see if Premiere will take the clip regardless of my players being able to show me it. Cheers

    @eyefi thanks for the info and links. Gonna split the file first as it is 1GB and slowing all attempts down! Edit: TSmuxer just flashes a command prompt for a millisecond & disappears (in Win7), not sure why but I can't use it.

    @radikalfilm If I just download CS5.5 will that be a quick fix? I don't have loads of time on this.

  • Yeah, I don't know what to tell you. I'm using CS6 and there's no issues there. 5DtoRGB doesn't give you full access to all codecs though. The software doing the transcode is actually more critical here than what online codec you use, otherwise there would be no reason to transcode at all.

  • here you can find the last version, the comments section seems to indicate their using win7: http://www.videohelp.com/tools/tsMuxeR

  • I have been using FlowMotion for several months and Premiere Pro CS6 exclusively for a long term project. I have shot in all kinds of lighting situations - extremely low light and intensely bright light - and have never experience this "digital rain" problem. There are so many variables involved (not just the hack and editing software), it is silly to lay blame on any one thing without researching it further. There's been so much alarm in several posts that I find quite ridiculous.

  • I saw this "digital rain"/"zebra stripes" stuff for the first time this weekend. I was shooting FM 2.02 and imported into Premiere CS6. It was pretty strong on a few shots. I'm not blaming it on FM--that's just what I was using. However, I would love to know if there are any patches that do not exhibit this behavior in CS6. FM has been a great patch for me with its good data rates, look, and reliability--but I really don't want to transcode my footage before importing it. I thought this was behind me.

    Is anyone finding a workflow in CS6 that eliminates the rain without transcoding all footage?

    Thanks

  • @DouglasHorn I've used Apocalypse Now Boom version 1 and Apocalypse Now Intravenus Version 1 in Premiere CS6 (Windows) and haven't had any issues with digital rain. FM has been problematic for some in CS6. I've also used the recently released trials 3 and 4 of the Moon setting, without any digital rain. Moon may be the closest setting to FM in terms of look. I believe @lpowell has been looking into this, so perhaps he can chime in here with his thoughts as I'm sure he'll know best. Most people use FM 2.02 without any issues, but a few have been hit with the "rain" in CS6.

  • @saltherring I find your post ridiculous. CS6 in floating-point mode transcodes the incoming MTS to RGB very poorly. Case closed. There may be other software that makes similar errors but that's mostly incidental. The most common variable is CS6.

    It's not a patch issue at all. You should maybe do some a dem researches yourself, maybe?

    @DouglasHorn just transcode with 5DtoRGB. It's not your patch. It's not any patch. It's CS6. It only shows up in certain types of footage but it's not actually in the footage. The solution is simple. No need to change patches. No need to change shooting style. No need to second guess whether it's actually in the raw footage or not. It isn't.

  • It's true. Transcoding is the answer and solution that allows you to keep everything the same about how you work (particularly setting choice). But if you despise transcoding, I think some people are reverting back to CS5.5 and having success. This my allow you to keep a favorite setting, if CS6 isn't working with it.

    @BurnetRhoades Interesting what you said re CS6 transcoding MTS to RGB poorly. I'm not as experienced...so does this mean CS6 tends to make the colors less accurate from MTS that are simply dragged into timeline, versus using 5DtoRGB to transcode MTS files and then bring in to CS6?

  • They're less accurate in terms of putting the diagonal "rain" where there was none. Similarly, that latest DNxHD codec, when working floating point, shows bad pixels that aren't representative of the footage. Of the non-error parts of the frame I really couldn't say whether they were rendered accurately or just with more subtle error. I just know I no longer trust it.

    I will say this, for my short subjects where I went back and did the transcode I didn't really notice any differences on the AE timeline versus when I was reading in the MTS directly except for my Trick or Treat with the Rolands which has people all throughout. Without being a gamma issue, all of that being equal, I noticed that I could see much more subtle gradation and lighting on faces with the 5DtoRGB footage and could also see more gradation in the dusk skies.

    Like, there's a scene in my brother's family room near the end where it's really dingy, warm, incandescent light and then this blue light coming from the big ass TV he has hanging on the wall. In the original version, which rendered with "rain", I couldn't see any light hitting their faces. In the 5DtoRGB footage I can see, all throughout the footage, these subtle, bluish highlights and tones on my niece and nephew's faces. And that's running it through the same project file. So, any future versions of CS6 that may supposedly fix the issue, I already have plenty of footage to test with to see just how well they fix it. (plus all of this footage uses virgin firmware)

  • Luckily everything I'm exporting is looking good for me so far.I use CS6, but I'm good so far. Will do a DCP test soon and that should cover all possible screens/audience experiences. Thanks for heads up though. Always good to maximize quality all the way thru pipeline.

  • @matt_gh2 Are you rendering straight out of Premiere or are you side-loading into AE and rendering there from a float timeline?

    CS6 Premiere seems to fair better than rendering in AE. I just never render anything out of Premiere but audio so I can't personally confirm. I always render out of AE, I just prefer the grading tools there and even for titles I don't like the way they work in Premiere. Plus, now that we can do not only floating point but linear-light floating point, I'm all about that, doing old school optical style stuff that always had to be "faked" in previous versions.

  • @saltherring actually, no, I didn't, I didn't appreciate how you were adding ambiguity to the issue that shouldn't really exist anymore. It's clear where to point the finger. Mistakes get made, happens with every tool, hopefully Adobe is able to fix it soon. Until then there's a fix. No reason to over-think something nobody but Adobe is going to be able to fix.

  • @BurnetRhoades @saltherring Actually no, MainConcept has to fix it, as it's their decoder. Adobe links to their libraries (hardcoded it seems, as it doesn't behave like a proper DirectShow decoder). The fix will trickle down...eventually, but first Adobe has to take this issue up with MainConcept.

    I've seen the rain even with the stock firmware, and yes there are patches that decode without the rain.