Personal View site logo
Make sure to join PV on Telegram or Facebook! Perfect to keep up with community on your smartphone.
Touch-AF on the GH2 - help!
  • Guys, I'm embarrassed to ask such a basic question given I know my GH2 very well, but I'm away from home on a fairly flaky connection and can't keep the internet alive long enough to find the answer. Basically, in the past I've used the touchscreen to focus on my GH2 during video recording, but now when it's recording, I just get the yellow "set AF area" box rather than it actually controlling the focus. I'm pretty sure I must have changed a setting during a firmware flash but I can't work our what. Whatever menu item I try I get the yellow box rather than actually controlling focus.

    Just to be clear, I can use the "half press" shutter thing to control AF, but not the touchscreen. What am I doing wrong? Cheers!

    For info: using firmware 1.1-based Cake 2.0 patch.

  • 16 Replies sorted by
  • Hi Mark, never relly use this function when I record (apart from leica 25 summilux have only FD lenses). But after reading your post I try it. During recording I can touch the screen to set the AF area and then when I half press the shutter button the camera focus on the selected area. If I remember correctly with the old firmware the camera focussed directly by touching the screen. So I think is because the 1.1 firmware. (I actually have Orinio dark matter v3 on mi camera).

  • Ah, thanks Kihlian. I haven't used the touch-to-focus thing for a while myself, so you may well be right that it's a function that disappeared with the new 1.1 firmware. The half-press thing is a bit sensitive (which means it's easy to accidentally stop the video recording by pressing too hard) hence the touch-thing was occasionally useful.

    Thanks again, I think you're right.

  • Sorry to hear of your problem, Mark, but touch focus definitely works with 1.1 update. Indeed the whole screen is now active…and smoother, I think. Something is afoot with your patch or…whatever. Me no know

  • Ditto what davhar said. Touch focus working on screen during recording 20mm pancake. maybe you have some settings disabled in cam menu.

  • What is your Autofocus dial set to? A buddy of mine was freaking out on me with the same issue till he realised his gh2 was set on MF.

  • It should change focus point while recording just dont mind set menu and yellow color. Settings might have affect on speed of focus sometimes.

  • Hi all, thanks very much. Nice to know it's still possible in theory - but I've had a look at all that, and still no dice. I even reset everything but no good. I'll reflash the firmware and try again when I get home.



  • Did you set afc to afs on top of the gh2?

  • Yup - did that! Thanks for suggestion tho'. AF all works as expected on the shutter release (half-press) just not on the touch-screen. I get the yellow "set area" if I touch the LCD and can move it around and set the area but that's all - it still only focuses using the shutter press and not at all using the LCD.

  • ps, it works here not always, i need something with good contrast, otherwise it wont focus throe touching the screen.

  • Maybe you have set the af mode dial to 23-Area-Focusing instead of 1-Area-Focusing (the lowest one)?

  • Thanks all - none of those things unfortunately - so I will reflash and see if that solves it. I'm guessing Cake can't be the culprit can it?

  • Hi all, an update: tried resetting everything that can be reset, then reflashing with Cake 2.2.

    I've looked at @otcx video above and tried again with my GH2 / 14-140 and realised that mine DOES focus - but it's VERY slow and only works some of the time compared with using the shutter half-press with exactly the same subject.

    This is not how it used to work with the old firmware (touch af used to have the square which went green when the area was in focus, and again that was just as fast as the shutter half-press).

    With this yellow thing it's extremely hit-and-miss to the extent that I'm not even sure if it's doing anything half the time (again, same subject, using half-shutter-press, it's REALLY fast).

    It seems like this is a huge step backwards! So is this what we get now, as in the video above? It sucks!

    On the other hand, not life or death, just that it was occasionally really useful to do fast af by touching the screen.

  • Mark, do Menu, Setup, Reset after reflashing.

    Here's how I use the touch screen to change the autofocus area. I have the focus lever set to AFC or AFS, and the focus mode dial set to face detection or 1-area-focusing.

    Touch the center of the screen. A yellow box appears: this is your custom autofocus area. Move the yellow box to where you want. (you can also change the size of the box) The camera immediately focuses on what's in the yellow box. With Continuous Autofocus set to On (in the motion picture menu), the camera will refocus if a new object moves into the yellow box. With Continuous Autofocus set to off, it won't refocus: the focus remains fixed however it was set when it focused the last time you touched the screen to set the position of the yellow box. Press menu/set to set the new autofocus area and return to the normal display mode. Press menu/set again to cancel the custom autofocus area and return to face detection mode. Regardless of the Continuous Autofocus menu setting, you can half press the shutter button to make the camera refocus on what's in the yellow focus area.

    This is on pages 43 and 84 of the manual.

    Using the Lumix 14-140 lens when recording video, it's taking less than one second to refocus each time I touch the screen. It takes just as long to refocus when I half-press the shutter button. When I'm not recording video, it focuses much more quickly. I don't recall this being any different in the v1.0e firmware

  • @balazer Thanks so much for your full explanation. I did a walkthrough of your explanation above and that all makes perfect sense and works exactly as you so very well described.

    It's nice to have this function as it was always a bit tricky using the half-press to focus (as if you are not careful it will stop the recording). I think I was panicking a bit as I just assumed it wasn't working, but it does make huge sense that it works as you described.

    Thank you!!

  • EDIT: And thank you everyone else above too!!