Personal View site logo
Make sure to join PV on Telegram or Facebook! Perfect to keep up with community on your smartphone.
Please, support PV!
It allows to keep PV going, with more focus towards AI, but keeping be one of the few truly independent places.
  • Hi Folks,

    I'm extremely sorry to be reporting any negative to this AMAZING hack/setting, but I went out on a FREE (Thankfully) Band Shoot last night with my GH2 under the Cluster v6 DrewNet patch. I'm using a SanDisk Ultra 64gb card (30 Mbit/sec) and I set the GH2 to the Lower of the two settings both for disc space and extra stability. With these settings I'm getting 2 Hours and 55 Mins on the card with a 50 Mbit/Sec Data Rate (equivalent to 100ish...Yay!)

    After the first set I shut the camera down, and when I re-powered on for the second set (with still an Hour and 50 mins left on the card) it gives me this VERY unpleasant response when I hit the record button...


    I gave it my best "college try" with powering down, card in and out, in a desperate effort to get it to record again, but alas it just laughed at me. (and a hacked GH2 has a very unpleasant laugh, let me tell you)

    I'm DESPERATELY hoping there's something silly I'm doing, or a work-around that will fix this, as the v6 Cluster was SPANNING LIKE A CHAMP! I've tested it out to almost THREE HOURS more than once and it's doing it. But I've never shut down then tried to resume as I did last night.

    If the only solution is to bend over on the price of an Extreme Card, I would gladly do that if it WILL solve this, but I get the feeling it won't and I'll be stuck paying WAY too much for a card that will go for $50 at some point down the road. (That always P's me off...the Ultra 64gb was $45 and it was working FINE other than this new glitch...and I'm not sure it's the card necessarily...I'm under the 60M point...)

    Anyhow, I again apologize for reporting less than great news, and I'm truly hoping someone has a solution out there in the land of innovative photographic genius!

    Take Care, Erik

    PS: With an old Nikkor 50mm f 1.4 lens on the GH2, and in a DARK restaurant - it was like I had a LIGHTING CREW on the band...UNBELIEVABLY nice!

  • 21 Replies sorted by
  • Another "out of the box" solution for this may be to buy additional Ultra 64gb cards and simply pop a new one in for each set/act of a play (something I do regularly) and this would cost MUCH less than an Extreme right now and give me "Mucho de Storage-O"

    Just a thought...

  • @quadrabay next time do what @driftwood says, then you will not have any problem with it.
    After a long take, do another short one, and then power down your gh2.

    ps, you better shut post this in driftwoods topic, and if you did read all the post in there, then you would now this..

  • @mozes what is considered a "long take"

    Do you mean "after a take which spans at least once, then be sure to do another new take which is short enough not to span, and then power cycle the camera" ??

  • The number added to the end of each file name has reached it's limit. Go into the setup menu and on the 5th screen select "No. Reset" to reset it back to 000.

  • And yes, the first time I encountered this on a camera I spent ages thinking there was something wrong with the SD card too, it's not the clearest error message!

  • @ethanpil Yes,
    @sam_stickland When you format the card in the cam. i was thinking that nr is reseted?

  • @mozes I just checked and it looks like the video files start renumbering from zero, but the stills don't :/ Still worth a shot!

  • This is a known GH2 problem I believe It is caused by the specific situation you mentioned: Shooting a long file that spans, then shutting off the camera. It happened to me last week on a shoot with a 64mb 95 card, its not the card speed, its shutting the camera off after a spanned file. I had to swap cards, dump the locked one and format it to make it work fine again.

    The only solution: record a small file after any long recordings if you plan on shutting off the camera. I've tried it, it works.

  • I have GREAT NEWS! I've tested the Work-Around for this minor nuisance and it WORKS! YAY! I let it go long enough to create at least one Span, and BEFORE actually turning the camera off I just recorded a quick 10 second clips (it ALWAYS keep working when the cam is on to my experience) and THEN shut the camera down. Upon restarting the camera and hitting the Record Button - YES - that gorgeous BEEP of recording. This work-around is a Godsend for me as I'd really like to keep my GH2 in v6 mode, but I routinely shoot 2 hour plays and I NEED it to keep going for at least an hour for each act.

    I'm VERY grateful to @mozes for hipping me to this great work-around. Thank you very much!


  • Is this a "problem" on all of the Driftwood hacks? or just Cluster V6?

  • It sounds as if it's a GH2 problem, but I'm not positive. I can say for sure that my GH2 has mysteriously just stopped recording UN-Hacked, so it "feels" as if the GH2 has this occasional weakness. I use multi-cams when I capture theater shows, so I can live with it, but I'd certainly prefer it to keep on goin'.

  • I really appreciate everyone's attention to this!

    Thanks for the help, Erik

  • It's a general GH2 thing, not just Driftwood hacks.

  • Well, I finally got this dreaded message and can only add that if one, like me, shoots some stills along with video, you may experience this shutdown sooner rather than later. Since I've been bit by this more often than not of late (guessing it's because I finally sprung for some recording time via purchase of a 64mb 95 card), i.e. caught by surprise, I'm not sure you are safe with the 10 sec. idea simply because I do believe that, in the attempt to do that 10 sec. clip, you may fall into the error. As I said, I often shoot mixed still with video so it may be that is complicating the problem. However it doesn't really matter since, assuming this is a GH2 issue, it should be addressed by Panasonic. I'm sure the only way to even hope to get their attention is to create the problem using a 100% stock camera. Note that a dvxuser posted on this problem using only a 32gb card and, I assume, a stock camera. ( If anyone has any other input/ideas on this, would be greatly appreciated as I've had to appy @yachacha's solution which totally defeats having a large card. I did try Panasonic support on this issue; the "resolution" was to send the camera to their repair shop! P.S. using Drewnet Trial 6 and having a hard time convincing myself to try anything else!

  • Addendum. This problem is becoming quite maddening as it is impacting shooting ability. Here's some observations. I don't recall ever having the problem with a 32gb card but am getting it regularly with 64gb. The 10 sec. workaround may or may not work depending if there are stills or not. So, put both cards in a PC card reader and properties them. LO! The 32gb card is camera formatted to FAT32 whilst the 64gb card is formatted exFAT. As a matter of difference, the cluster size of an exFAT disk is 128KB in-cam formatted whilst the FAT disk has a 32kb cluster size. Beginning to suspect that this may be the cause of the problem; i.e. something ain't quite right in the management of the "larger" format. Not sure how this fits with the dvxuser post where the problem seems to exist with a 32gb card (note though he had other strange problems like not being able to copy from it). OTH, following the PV thread referenced seems to morph into a 64gb card. Hmmmmm.

  • I am perhaps missing something here but did you try to reset the file numbering, I had this same error and my files were on 999 or something like that. You can do in the camera, forget exactly how but this worked for me with one of the hacks.

  • As an FYI, this happens to me every time I accidentally turn the camera off will recording instead of stopping first. Yeah I know, dumbass move but sometimes when I'm in the middle of a crazy ass shoot and am wearing 5 hats, it happens.

  • @quadrabay, @dtr doesn't seem so; no info on 'net showing this as a problem; references point to PV only. Yet, an unhacked GH2 would easily go beyond the 4GB boundary. @AfricaGH2 - wish it were that easy. I'm nowhere close to 999; for example, last two cases of problem were at file number 6 on one card and number 17 on another. @vicharris, wish 'twere so here! So, just to try to bring this to some kind of closure: can anyone definitively confirm this problem local to moded cameras or to only certain mods?

  • This "file number exceed limit" happened on a hacked GH2 Insanity 5.1 and a Sandisk 45MB/s Extreme card.

    Was able to fix it by switching off the camera, taking out the SD card and putting it back in.

    See if it works for you.

  • Okay, so last night I was shooting my kid's performance of "The Wizard of Oz" with my GH2. I shot the first half up to intermission and then powered down (I didn't know about this issue). When I tried to shoot the second half I got the dreaded "Cannot Record File Number Exceeds Limit".

    I was only really worried about batteries for this shoot since I had a 256 GB card, and of course I didn't bring a backup SD card. Lesson learned!!! Anyway, I had to shoot the rest of the performance with my iPhone 5, and its batteries ran out just as they got back to Kansas. Needless to say I was extremely disappointed.

    But when I got home I found this thread and realized the problem. I decided to do some tests, and I found out what needs to be done to fix the problem. First, always bring an extra SD card or two to any shoot.

    Second, make sure to bring a laptop with an SD card slot in it to every shoot as well. If you get the "Exceed" warning, you can fix it by inserting your card into your laptop, then go to UNTITLED >>> PRIVATE >>> AVCHD (right click on it and choose Show Package Contents) >>> BCVM (right click on it and choose Show Package Contents).

    At this point, open the Stream folder and scroll down to the last entry and see what time it was saved at. Then go back to PLAYLIST and find the MPL file that was saved at this time. Delete that file (for instance, Delete 00012.MPL).

    Eject the card and insert it into your camera. Start filming again. This seemed to work every time for me.

    These MPL files store the names of the clips that were shot in that last session, and for some reason if they end on a clip that spans more than one file (in my case it seemed to happen when it spanned 2 or more files), and you don't shoot another clip after it, you get this warning that is virtually impossible to fix in camera as far as I have found so far.


    You can actually shoot clips all the way up to 99000.MTS. After that, it actually exceeds the file number limit for real.

    The numbering of the files is based on two things: The highest number of the .MTS clip in the Stream folder, and the highest number of the CPI file in the CLIPINFO folder. The camera looks at these two folders and sees which one has the very highest number, and so the next file is incremented by one.

    Lets say for instance you just shot a file called 00111.MTS. When you shoot that file, it automatically generates a corresponding CLIPINFO file 00111.CPI. If you put the card in your computer and you just delete the 00111.MTS file, but you don't delete the corresponding 00111.CPI file, the next file that you shoot will be 00112.MTS.

    However if you delete the file in your GH2 camera, it will automatically delete both the MTS and CPI files together. So in other words, when you tinker around with the files on your computer, be aware that it may give you unexpected results.

    The positive benefit of this all is that I have always been shooting clips that look almost identical in number always starting at 00000.MTS and going up to around 00065.MTS or thereabouts. So everything looks the same. Now if I want to start a shoot that has different numbers, I will put in the new SD card, shoot a very short shot. Then put it in my laptop, open the STREAM folder and relabel that first shot to say 01000.MTS. Then when I start shooting the next video will be 01001.MTS and up. Later if I am shooting something else on that card, I shoot another short shot and put it in the computer and relabel it 02000.MTS and so on and so forth. Just so I don't get up to 99000.MTS which is the last file number acceptable.

    So if you forget to shoot a short shot following a spanned clip, just remember: Always bring extra SD Cards at a minimum. Then having a laptop to delete the offending MPL file so you can continue to use the SD card if you mess up. And for extra credit, change the file numbering so you have distinct clips up to 99000.MTS.

    Anyway, I hope this helps someone.


    Lane Wyrick

  • Yes, it really works! After deleting the mlp file, you can continue shooting. Thanks, bro!!! You're the best!)