Personal View site logo
Make sure to join PV on Telegram or Facebook! Perfect to keep up with community on your smartphone.
Z-CAM E2 First Hack Released!
  • First custom firmware for Z-CAM E2 is READY!

    Finally, I managed to figure out all my code and make a hack with Panasonic-like recording indication based on firmware v0.93!

    My first changelog:

    • Added automatic non-switchable red Panasonic-like recording indication along the edges of the HDMI-output

    All the source code of the added patches is here:

    The instructions for self-assembly of the firmware are described by me in general form here:

    I draw your attention that this firmware is NOT OFFICIAL, and also remind you that you do any manipulations with the camera at your own peril and risk! From now on, I disclaim responsibility for possible problems with the camera if you decide to use the assembled firmware! Be extremely careful!

    IMPORTANT! The hack is based on Z-CAM E2 firmware v0.93. Therefore, it will work ONLY in conditions where the official firmware v0.93 is running. For example, if you already have firmware v0.95 or higher on your camera, then installing firmware v0.93 (according to the assurances on the official Z-CAM website) is impossible! Consider this! The easiest way is to first roll v0.93 onto the camera, and then on top of it install my hack. So you can be sure that if the camera does not start after the first firmware installation process, this has nothing to do with the hack itself.

    How to start using hack:

    1. Your camera must be flashed to the official version 0.93.
    2. Download the firmware file from the link.
    3. Put the downloaded file in the root of your camera's disk.
    4. Flash in the standard way as if it were an official firmware.

    Custom firmware file link:

    1920 x 810 - 111K
  • 5 Replies sorted by
  • Hi there!

    Great someone is hacking the Z-Cam!

    My name is Bernd, I’m an artist & filmmaker in Berlin. I’m not into coding, but I own a Z-Cam E2C and I’m trying to solve a bug that bothers me a lot. I am actually using the camera for a slightly unusual purpose, it’s part of a home made scanner for 16mm and 35mm film, so it’s basically supposed to take many many DNG still images all day. The camera is triggered by a microswitch that’s attached to the scanner’s mechanics. The microswitch sends a trigger to a Raspberry Pi which then releases the camera via Ethernet cable. This works really really well and the results look stunning. I have tried out quite a few other camera models (Sony A7S2, Fuji X-T30 and Lumix G9), but they all failed the test, mostly because their RAW files weren’t compatible with my workflow and it would take me ages convert these many files into an editable format. At the end of the day the E2C fits almost perfectly into my setup in terms of compatibility (the conversion to CinemaDNG happens in real time), image quality and usability – if not …

    …if the camera wouldn’t suffer from a major flaw that has been driving my crazy for the whole last year: It only writes a maximum of 9999 DNGs into the first folder (sometimes only 9998). Then it stops shooting and asks me to manually set the meta settings in order to continue. By the time I notice that the camera has stopped shooting, my machine has already moved the film forward, so I have to abort the whole process, manually rewind the film back to the spot where the camera has stopped grabbing frames, set up the camera agin, check the focus and so on… This is really annoying, also because it forces me to always stay nearby the machine and supervise the process. It really affects my life that way.

    I have tried to get in touch with the Z-Cam support on all FB channels, Reddit and on Email, but the only response I ever received about a year ago was „this is our current design“. There haven’t been any firmware updates or bugfixes ever since. So reading your post I thought maybe modifying the firmware could be a solution? But I have no clue how & where to start, and can’t even estimate how much work this could be. I think this is probably a file naming issue, since the camera doesn’t even look at the real number of files in the folder. Instead, it just stops at file number 9999, even if there are less files in the folder. Maybe the easiest approach could be to enable the camera to write up to 99999 (5 digits) files into one folder, if that would be possible, it would completely solve my problem!

    It would be great to hear what you think about all this, so at least I can tell whether there is a perspective for solving this problem (or not).

    all the best Bernd

    Z-Cam reached maximum file number 9998.JPG
    2382 x 3070 - 739K
  • Why don't you program your raspberry to stop the reel at the count of 9999 shots, and then you can repeat the whole process from that point. I have do it something similar in the past with stepper motor and arduino. You can see my prototype here:

  • Your colour grading is really amazing, especially since everything was faded to magenta! How did you manage to recover the greens? Your stepper motor suggestion would be a compromise, but require me to change my setup quite a bit: currently the machine is run by a 12V wiper motor. Replacing this with a stepper motor would be possible, but the question is whether this is worth the effort, since I would still have to interrupt the scanning process. So at this point I still hope I can solve the 9999 stills limitation, since that would allow me to scan any reel in one chunk…

  • I use a restoration software called "Film9". I think is a free windows frontend with virtualdub/avisync software and restoration pluggings. Really easy to use for people like me, with few to no grading skills.

    I used a a stepper motor because with my modded euming projector, 1 turn of the central axis (360°) was exactly next frame, and so on. So I can count steps and count frames exactly, without dropping anything. Another reason was the bottleneck of my lumix camera buffer, so I can't go faster than 1 frame/second, and no raw possible. I added a little magnet on one of the blade and hall effect sensor, so I can reset the initial position of the frame at one precise point. (booting my system, arduino don't know where the stepper position is, so magnet mark the starting point.)

  • Oh it's Avisync... As a Mac user I still have to figure the colours manually... Not sure if I could get those greens from nothing... My machine is currently running at 2 FPS, but a friend of my had written me a small script for testing the Z-Cam and with a fast SDD attached we got up to 4 FPS in RAW (DNG). But there's a risk of skipping frames if you go too fast, so for me 2 FPS is fast enough and somewhat safe...