Personal View site logo
GH1: setting "Varigop" - superb IQ - integrated timelapse in MJPEG
  • 50 Replies sorted by
  • @tinbeo SDXC cards can be used in the GH2 but not in the GH1

  • I use SanDisk Extreme Pro 45MB / s. Camera freezes after 15 seconds with card error.

  • Thanks for your feedbacks, guys. I will try with some advices, hope some might help:

    @yyeah my question was: did you use 24p (FHD) mode for the grass shots when your camera freezed? 24p mode is usually rock stable, please try the same kind of shot with some vintage lens and set NR not higher than -1 and let me know if the error happened again. The problem might have been caused by the Panasonic 14-140 lens. I like that lens, but it is not fast, it has strong optical distortion which gets corrected by the camera in real time frame by frame and camera also boosts the sharpening with that lens. Distortion correction and sharpening challenge camera's processing power near to its limits and it might cause problems in combination with the "Varigop" which needs nearly all of what GH1's CPU can do. Read about the distortion of that lens here:
    http://www.photozone.de/olympus--four-thirds-lens-tests/682-pana14140?start=1
    However, I had no problems at all with the Pancake 20mm f/1.7

    @kolargol Sandisk 45MB/s doesn't belong to the recommended cards for hacked GH1 and GH2 cameras. Its speed should theoretically be high, but practically it seems to be lower than by Sandisk's 30MB/s. There is lot to read about that in the threads, also in Faqs
    http://www.personal-view.com/faqs/gh2-hack/gh2-hack-faq
    I would sell that card on eBay and go for Sandisk SDHC Extreme Pro 95MB/s

    Guys, just one important information here: be aware that there are many fake Sandisk cards around us: higher prices of the Sandisk cards makes them interesting for the cheaters. Fake cards are often considerably slower than the originals, so rather pay few $ more by some trusted dealer and be sure you get original Sandisk memory card. Optically, the faked ones often look just the same....

  • @yyeah, @tinbeo, @kolargol guys, thank you very much for keeping me informed about the bugs. I confirm that the Varigop freezes very easily by recording grass or trees after some 15 seconds. The "card speed error" occurs no matter if Panasonic or vintage glass is used. I will try to improve the "Varigop" further and your feedbacks help me a lot for the development of this setting. I couldn't force freezing by shooting another highly detailed objects (also if green ones), but the reaction on grass and trees is unfortunatelly nearly allergic. I will report this bug in the first post.

    Last week I had very successful production with four GH1 cameras simultanousely running using "Varigop". It was a classical concert recording in excellent tungsten lighting. All four cameras ran for bit longer than 2 hours perfectly well, spanning worked in all four cameras perfectly fine. The sizes of the produced AVCHD files (24p, FHD) in little longer than 2h were between 18GB (tele lens) and 32GB (Panasonic 14mm f/2.5)

    EDIT 2013-08-02 unfortunatelly no more recommendation to use LPowell's high bitrate settings instead of "Varigop": both "Max Latitude" and "Blackout" are also freezing in the GH1

  • Dear "Varigop" users, I will soon have time to work on the bug. I hope it will be possible to fix the bug without considerable reducing of its high bitrates (freezing occurs as much I could test so far only if the grass or trees are shooting objects and tack sharp)

    Meanwhile, I am still using this setting for numerous concert events (simultanousely in 3-4 GH1's) and it just never freezed there, not once....

  • I've worked on the "Varigop" setting during last two weeks, searching how to improve its stability by keeping its high bitrates. Except some minor improvements I still didn't find the way to keep the stability absolutely under control.

    BTW: I must unfortunatelly also report here that in the test shootings where "Varigop" tends to freeze, also @LPowell's settings "Max Latitude" and "Blackout" which I considered so far to be rock-stable (and recommended to use instead in the GH1 instead of "Varigop") both have collapsed regularly and didn't make it to record even one minute without camera freeze (card speed error).

    Especially my shooting footage of lavender in the sunshine, tack sharp in focus, just slightly moving in the wind was simply impossible task for all those three high bitrate GH1 settings under 24p1080 AVCHD (FHD). Saying that, the lens I've used wasn't even the sharpest one can get (Minolta Rokkor 28mm f/2.8 at 5.6) but none of the settings made it to one minute mark without freezing. I've used the fastest SD card I have, several different units. (photo of the lavender is attached on the bottom).

    My dream is to find some rock-stable high bitrate setting for the GH1. I still use a lot my GH1s (I own four bodies) and really like them, especially in the low ISO situations it is still my favourite camera body. "Varigop" beta version is so far the closest to it.

    I will keep testings through longer time, meanwhile I tend to leave the "Varigop" just the way as it is, as in the most of shooting situations it doesn't cause any problems. I assume to possibly have faced the limits of the GH1 hardware which seems to have very tight data transfer bottleneck, which is either in GH1's buffer part- or in GH1's writing speed ability (the SD card slot).

    • "GH1 Survival Check List" :-) I share my impressions with all there who use high bitrate settings on their GH1 no matter if "Varigop" or "Max Latitude" or "Blackout" is flashed, mind following behaviour of the GH1 which I could observe and during my own tests:
      • GH1's card speed error happens preferably by shooting highly resoluted, well-lit green scenery (like leaves, grass etc) the more of the frame is in-focus, the bigger is the chance of camera freeze, it seems to me that the green scenery is especially difficult task for the stability of the GH1
      • the sharper the used lens is, the bigger is the chance of camera freeze
      • the wider angle of the used lens is, the bigger probability of camera freeze (I had no errors at all so far by using tele lenses) due to higher amount of details
      • smoother film modes are improving the stability of the GH1 (use preferably modes standard, smooth or nostalgic instead of vibrant, nature or vibrant)
      • smoother settings are improving the stability of the GH1 (saturation, sharpness, contrast and NR: rather all to -1 than 0, if the objects are contrasty, set all to -2 rather than -1. My personal advice: set the sharpness just always to -2)
      • slight underexposing improves stability, while slight overexposing tends towards card speed error
      • GH1 freezes easier if Panasonic lenses are mounted, as they challenge the small GH1's CPU to its utterly limits with in-camera sharpening and with correcting the optical distortion of the Panasonic lenses (both automatical, not switchable)
      • check whenever possible before an important shot if your GH1 is behaving stable in that scene and rather shoot few shorter takes than one long one, as if the camera freezes the data is lost.

    Any additional information by Varigop users, or GH1 experts who could help me to improve this setting are most appreciated!

    Here is the photo of the critical test shooting, how the lavender I've mentioned looked like. My GH1s weren't able to reach even one minute of footage before freezing, neither with Varigop, nor with Blackout, nor with Max Latitude (the lavender was moving in the wind):

    P1050300.JPG
    2048 x 1536 - 749K
  • im not able to download this hack file i can only download png image file instead. can someone help?

  • @waqarch make sure you're logged in and it should work. Zip file of the setting is in the opening post.

  • thanks tetakpatak. it worked :) also can u please suggest best patch for PAL 25p. i use 75mb path but motion is not very smooth even using stabliser etc mayb becos its interlaced. Sort of jerks in movement. Solution is very much appreciated. also if u got any solution for 2x anamorphic in VGA tht is not clean like FHD.

  • Try HQ3GOP instead.

  • @waquarch I've used for my own needs conservative 44Mb/s setting without any extras for PAL (25p) some years ago. Meanwhile, I use this "Varigop" 24p for it has such good motions and shadow details and I render afterwards to 25p.

    I really regret for not being able to stabilize this setting yet. I've spent several full days by testing it last summer but no real success yet. However, also all other high bitrate settings for GH1 are unstable. It might be also hardwere limitation. There are still some unknown options in Ptool where I hope to find reliable solution.

  • @tetakpatak I 've tried out the time lapse setting. Had I done it right, go to M ( picture mode ) setting shutter speed to 2 then hit video record. My question is how the result in mov format processed in Premiere?

  • @tinbeo I'm not sure if I understood your question. Your GH1 should be set to video mode / rec mode: Motion JPEG / rec quality: HD / exposure mode: preferably "M". Choosing exposure value to 1/2s will provide you smooth moving objects. 2fps is set by default for MJPEG recordings. By daylight you may need very strong ND filter (6-8 EV) and stopping down the apperture to f8-f4 respectively.

    But also shorter exposures may look OK, here is an example (maximal recording time, 1h22s rendered by "Timelapser"), unfortunatelly I should have rendered myself from 25fps to 30fps before uploading on YouTube, the clouds move much smoother in original file:

    For processing the MJPEG files best you can do is to download Jordan Noblet's "Timelapser" PC software which extracts, renders and cleans the files automatically. Final format is AVI 25p in good quality and it can be rendered later to whatever you prefer.

    For maximal recording length of the single file (about 1h22min the way I did the setting in the zip file for 1920x1080 with 4:2:2 colors) you will get after the rendering the final video file total duration some 40sec.

    If you need longer recording times, you can at any moment stop and start again the recording. Maximal file size for MJPEG recording is 2GB due to the formatting and it can't be extended.

  • @ totally nood of this 1/2s or 2 in shutter speed -:) . In Video M mode, I could only go down to 30 in exposure mode. But in Picture M mode, i would be able to go down to 2. Is that 2 number like 1/2 s? I used mac but remember another way in AE to process it from other time lapse post. Thanks for explain but still confused.

  • @tinbeo if you choose recording mode AVCHD, it is not possible to set the exposure beyond 1/30s value. But in MJPEG it is no problem, however the exposure mode (sub-menu of "motion picture") must be set to M to go beyond 1/30s.

    I have no idea about Mac, maybe it's possible to run the "Timelapser" in the virtual machine with iOS. But isn't Windows also installed in the newer Macs? Check Jordan Noblet's website, he may has mentioned what to do with Mac.

  • Is it normal for the lens not to auto focus during recording? 14-42 3.5-5.6 lumix mega ois

  • @cardosokilas Definitely not normal. It has nothing to do with the setting, as it doesn't influent the functionality of the lens focusing at all AMAIK.

    Check if you have moved the focus switch to "MF" (upmost left on the GH1). If so, you can focus only manually, by turning the ring next to the first lens element.

    If your focus mode is set to AFS, it should work during the video recording just like in the AFC, continously focusing the priority area that you can see on your EVF as well as re-focus by half pressed shoot button. The focus doesn't beep during the video recording.

    If this all didn't help, upgrade your lens firmware to the newest one. Otherwise it could be malfunction of the lens.

  • i have just discovered this for my aging but beloved gh1. Its refreshing...so far its been stable with me but varies in bitrate from 17mbps to 40mbps depending on the lens used and the detailed scenes. think I will try this to get my gh1 out of the cupboard

  • @blues exactly, the bitrate depends on the subject very much. Also how big part of the sensor is in-focus. The more details- the higher bitrate.

    I have discovered a crucial detail meanwhile: in the case that camera freezes (big problem of the GH1 in general by higher bitrate) it is very important to "stop" the recording as normal. The file can be easily restored afterwards in the PC by running chkdsk to fix the .MOV database of the corrupted file. It saved me last January!

    Unfortunatelly, VK has removed the possibility to edit posts for some reason, even OPs, so I can't edit my first post.

  • Hi. Is this, still the best way to timelapse with GH1??

  • Hi @juantonioconde, 2fps seems to be the most stable setting for time-lapse recording with the DMC-GH1 based on previous tests. This is an excellent patch which, in my opinion, provides a cleaner image than any of the hacks I've used on the GH2. This may also be due to the lower 12.1 megapixels (GH1) vs 16 megapixels (GH2) which provides the GH1 with larger photosites (better pixel density) over a similar/slightly larger sized sensor area. Essentially, this equates to better low light performance (GH1: 722 vs GH2: 655 DXO Mark) and slightly more dynamic range (GH1: 11.6 vs GH2: 11.3 DXO Mark) when all other variables are the same or as close as possible to each other.

    The highest overall bitrate for the GH1 with this patch in FHD 24p NTSC mode is 120mbps. Using the recommended SDHC card; SanDisk 32GB Ultra 95mb/s, highly detailed scenes may cause the GH1 to crash/freeze. According to SanDisk, the maximum write speed of this particular card is 90mb/s. The less than ideal SD memory card bus performance of the GH1 is one of the reasons higher settings cannot be achieved. That's understandable given the technology that existed in 2009/2010. Still, Panasonic were ahead of the pack when comparing their specifications to what Olympus was providing at the same time (720p).

    I'm going to reduce the bitrate of this patch from 120mb/s to 90mb/s to see if highly detailed scenes cause the GH1 to crash. I won't change any other settings at this stage. I'll post the results of my tests on here shortly.

  • Thank you @jimbo1169 I will wait for the bitrate reduction.

  • OK, well unfortunately no matter what reduced bitrate I tested, highly detailed scenes caused the GH1 to freeze. This is, of course, a well-known issue. By most accounts, it doesn't matter which patch is used. A limitation of the GH1. So the best workaround based on most forums relating to GH1 patching is to: (1) Reduce sharpness to -2 (2) Use a flat picture profile; Standard or Smooth with most settings to -1 or -2 (3) Format the SD card prior to recording (4) Reduce exposure compensation in well lit scenes. Long live the GH1!

  • Thanks, @jimbo1169
    I agree, the SD card slot of the GH1 is its data bottleneck. But I use all my GH1s regularly still today, as static cameras for long shots. It serves me great. When I need all in focus with a wide lens, I just use some other camera. Cheers (-:

  • @tetakpatak you used this in pal country? No issue with flicker if you use 1/25 or 1/50 shutter?