Personal View site logo
Cinema gear deals, direct from factories - Gear deals and Gear deals section. Also check Cameras, lenses, software, gear deals.
You support is vital for us. To keep this place ad free and independent, select one of the options below.
Donations are going to laboratory, support costs, hosting, etc. Your support allows to improve and expand this site.
Sony FE lens aperture control failure
  • Hi Guys,

    I'm on my once in a lifetime around the world trip and my Sony FE 24-240mm f/3.5-6.3 OSS broke down in middle of nowhere in Philippines.

    The problem:

    • Camera body (Sony A7sII) does not recognize lens aperture and it cannot be controlled. When switching lens on and off and flicking camera power the camera might show the right aperture just for 0,5 seconds and then disappear into -.

    • Lens aperture sometimes randomly "hunts" between aperture fully open and closed until it always gets stuck in closed (~f36).

    • Focusing works very randomly. Focus mode cannot be changed due to "Lens not attached properly or not supported"

    • Still photos can be taken (not in focus) but no video cannot be recorded.

    • There is a strange ticking sound inside the lens when camera power is turned on and lens attached.

    Tried fixes:

    • Contacts are cleaned and no physical damage can be seen on the lens. Other lenses Sony FE lenses work fine with the camera body.

    Have you guys experienced similar problems with Sony FE lenses??

    I'm truly getting desperate. :(